Go Back   The Ford Barn > General Discussion > Model A (1928-31)

Sponsored Links (Register now to hide all advertisements)

Reply
 
Thread Tools Display Modes
Old 06-03-2015, 05:02 AM   #1
My1930ModelA
Member
 
Join Date: Feb 2015
Location: New Philadelphia, Ohio
Posts: 32
Default Speedometer Cable question

I'm replacing my speedometer cable and have run into a problem....1930 Town Sedan with an oval Northeast speedo. The threads on my new cable on the speedometer end are male threads, but my Northeast speeometer requires female threads on the cable housing. Has anyone run into this?

Thanks
Mark
My1930ModelA is offline   Reply With Quote
Old 06-03-2015, 08:53 AM   #2
Mark in MT
Senior Member
 
Join Date: May 2010
Location: Western MT
Posts: 214
Default Re: Speedometer Cable question

Sponsored Links (Register now to hide all advertisements)
The oval Northeast speedometer uses a cable assembly that is unique to that speedometer. Those units are rare, I only have one for parts in the shop and no cables. When I get to the shop I will check the size of the square drive of the input, you may be able to use a "standard " inside cable in your housing.
__________________
Mark in MT

Always looking for another opportunity to be wrong.
Mark in MT is offline   Reply With Quote
Sponsored Links (Register now to hide all advertisements)
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Sponsored Links (Register now to hide all advertisements)


All times are GMT -5. The time now is 03:10 AM.