Go Back   The Ford Barn > General Discussion > Late V8 (1954+)

Sponsored Links (Register now to hide all advertisements)

Reply
 
Thread Tools Display Modes
Old 03-29-2019, 10:36 AM   #1
Teacher John
Member
 
Join Date: Dec 2018
Location: Bastrop County, TX
Posts: 51
Default Clifford Performance

Has anyone here used Clifford Performance recently? I purchased a header and intake manifold set up for my 1964 Ford 262 inline six project. I had so many problems with their products. The header had tabs on it that needed to be grinded away so that it would fit with the intake and bolt against the head. Pain in the arse. Then we found that the intake manifold flange was 1/8 inch thicker than the header flange thereby prohibiting the two from forming a tight fit against the head. This caused the manifold gasket to blow out. I had to take the intake and header to a machine shop to have them milled to alleviate the problem. Now it works great. What a pain.
A buddy of mine in CA experienced the same problem with a similar setup for a 235 Chevy.
Clifford used to provide high-quality products. It all went to shite now.
Teacher John is offline   Reply With Quote
Old 03-29-2019, 10:57 AM   #2
54vicky
Senior Member
 
54vicky's Avatar
 
Join Date: Dec 2011
Location: Oakville Ontario
Posts: 374
Default Re: Clifford Performance

I agree with their products years ago were the cats ass now perhaps they no longer have the cat.may be that like a lot of bygone quality products coming out of the far east sign of the times sadly
54vicky is offline   Reply With Quote
Sponsored Links (Register now to hide all advertisements)
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Sponsored Links (Register now to hide all advertisements)


All times are GMT -5. The time now is 04:21 PM.