Go Back   The Ford Barn > General Discussion > Model A (1928-31)

Sponsored Links (Register now to hide all advertisements)

Reply
 
Thread Tools Display Modes
Old 05-07-2010, 11:21 PM   #1
Karl
Senior Member
 
Karl's Avatar
 
Join Date: May 2010
Location: Manawatu, New Zealand
Posts: 973
Default Brakes Help Please

I like the new forum but hope it's as helpful as the old one was. Since installing Teds floaters I've had lots of problems with shuddering of the brakes. Finally we traced it to out of round drums and a loose tie rod end Thats all fixed now and the car drives and stops straight with no shudder. However when I apply the brakes when I'm travelling slowly and turning left I get a groaning vibrating sound from the left front wheel area. Doesn't happen if I'm not turning or if I'm turning right . What gives ?? I can't work this one out -Thanks Karl
Karl is offline   Reply With Quote
Old 05-07-2010, 11:24 PM   #2
pat in Santa Cruz
Senior Member
 
pat in Santa Cruz's Avatar
 
Join Date: May 2010
Location: santa cruz, calif
Posts: 2,009
Default Re: Brakes Help Please

check for possibly loose bearings allowing the drum to shift and mis align from the shoes

Last edited by pat in Santa Cruz; 05-07-2010 at 11:38 PM.
pat in Santa Cruz is offline   Reply With Quote
Sponsored Links (Register now to hide all advertisements)
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Sponsored Links (Register now to hide all advertisements)


All times are GMT -5. The time now is 11:42 AM.