Go Back   The Ford Barn > General Discussion > Model A (1928-31)

Sponsored Links (Register now to hide all advertisements)

Reply
 
Thread Tools Display Modes
Old 08-16-2012, 06:28 PM   #1
c125bob
Senior Member
 
c125bob's Avatar
 
Join Date: Aug 2012
Location: Chattahoochee Hills, Ga
Posts: 143
Default Replaced water pump and fixed exhast leak

Changed the water pump to a "leakless" but not "greaseless" style pump today. My old one was trashed and shaft grooved up. Previous owner had tightened the packing nut beyond belief.

Also, had a BAD exhaust leak right at the manifold. New clamp seal and collar inserted in muffler inlet and exhaust manifold solved the issue. The A sounded like a pulpwood truck !

Next on the list is the light switch housing. Old one is worn out and coming apart. I'll have to take the harness loose from the car and thread it through the new housing. P.O. should have changed the housing when he installed the new harness ! Lights and horn will work on the bench but not in the car. When I removed the old case and spider I could see why. Trashed as well.

Running as risk here but...... I think I'll be good to go after that but you know how that goes !
__________________
Bob
1930 Tudor
Chattahoochee Hills, Ga
c125bob is offline   Reply With Quote
Sponsored Links (Register now to hide all advertisements)
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Sponsored Links (Register now to hide all advertisements)


All times are GMT -5. The time now is 08:07 AM.