Go Back   The Ford Barn > General Discussion > Model A (1928-31)

Sponsored Links (Register now to hide all advertisements)

Reply
 
Thread Tools Display Modes
Old 07-29-2012, 06:21 PM   #1
ed thibodeau
Senior Member
 
Join Date: May 2010
Location: Pinckney, Mich.
Posts: 135
Default rear main seal

Picked up a used engine that was running in early spring and tore it down to see that everything was OK for a backup. It had been leaking at the rear main. When I pulled the rear main cap the crank had been machined to remove the rear slinger and a rope seal similar to the front pan seal was in the cap and the block. Is this somthing that I can live with or do I need to get another crank, babbet etc.
Thanks:
ed thibodeau is offline   Reply With Quote
Old 07-29-2012, 07:39 PM   #2
James Rogers
Senior Member
 
James Rogers's Avatar
 
Join Date: May 2010
Location: Asheville,NC
Posts: 3,098
Default Re: rear main seal

If it is leaking it would need attention. The problem is the rope that FelPro made for years is not available anymore and other seals are suspect, sometimes they work and sometimes they don't.
James Rogers is offline   Reply With Quote
Sponsored Links (Register now to hide all advertisements)
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Sponsored Links (Register now to hide all advertisements)


All times are GMT -5. The time now is 06:05 AM.