Go Back   The Ford Barn > General Discussion > Early V8 (1932-53)

Sponsored Links (Register now to hide all advertisements)

Reply
 
Thread Tools Display Modes
Old 08-21-2018, 08:41 AM   #61
flatjack9
Senior Member
 
flatjack9's Avatar
 
Join Date: May 2010
Location: Oshkosh, Wi
Posts: 3,188
Default Re: 50 flatty idles well revs okay, but will not drive down the road.

Do you get a large enough signal from the venturi with no load on the engine to check advance? I have my doubts.
flatjack9 is offline   Reply With Quote
Old 08-25-2018, 08:22 PM   #62
trentclark
Junior Member
 
Join Date: Aug 2017
Posts: 5
Default Re: 50 flatty idles well revs okay, but will not drive down the road.

flatjack9, i dont know what you are asking. can you clarify a bit?
trentclark is offline   Reply With Quote
Sponsored Links (Register now to hide all advertisements)
Old 08-25-2018, 08:26 PM   #63
trentclark
Junior Member
 
Join Date: Aug 2017
Posts: 5
Default Re: 50 flatty idles well revs okay, but will not drive down the road.

slowforty, on the charging system. took the gen out and checked the innards for being grounded out. it was. cleaned up the armature and it checked good. when I would spin it on the bench voltage was being created. reinstalled and now when it is running i dont get a drain on my battery like before it just stays level a 12.30 volts. shouldnt it ramp up the voltage when I rev the motor? dont know much about generators and prefer to get it working.
trentclark is offline   Reply With Quote
Old 08-25-2018, 08:27 PM   #64
trentclark
Junior Member
 
Join Date: Aug 2017
Posts: 5
Default Re: 50 flatty idles well revs okay, but will not drive down the road.

also, when installed on the truck and running, it shows to put out .5 to 1.5 volts when revved. doesn't sound like much.
trentclark is offline   Reply With Quote
Old 08-25-2018, 09:11 PM   #65
Tinker
Senior Member
 
Tinker's Avatar
 
Join Date: May 2010
Location: MN
Posts: 3,653
Default Re: 50 flatty idles well revs okay, but will not drive down the road.

Quote:
Originally Posted by JSeery View Post
If you are going to drive it with the vacuum hooked up, you need to check it with the vacuum hooked it. It in not like a later distributer with both mechanical and vacuum advance (assuming original loadamatic), it only has vacuum advance and will not operate as designed without the vacuum connected.

on a vacuum advance 8ba for initial you want about 4-6 degrees btc. w/ Vacuum advance disconnected and plugged.


Am I missing something? 22 degrees is way to much for initial timing. But i could be wrong.
Tinker is offline   Reply With Quote
Old 08-25-2018, 09:12 PM   #66
Tinker
Senior Member
 
Tinker's Avatar
 
Join Date: May 2010
Location: MN
Posts: 3,653
Default Re: 50 flatty idles well revs okay, but will not drive down the road.

Quote:
Originally Posted by trentclark View Post
slowforty, on the charging system. took the gen out and checked the innards for being grounded out. it was. cleaned up the armature and it checked good. when I would spin it on the bench voltage was being created. reinstalled and now when it is running i dont get a drain on my battery like before it just stays level a 12.30 volts. shouldnt it ramp up the voltage when I rev the motor? dont know much about generators and prefer to get it working.

yes it should.maybe a regulator issue. Have your wife or a buddy hit the throttle while you put a volt meter on the gen. Isolate the issue.



maybe start your own thread too, just a thought

Last edited by Tinker; 08-25-2018 at 09:40 PM.
Tinker is offline   Reply With Quote
Old 08-25-2018, 09:48 PM   #67
JSeery
Senior Member
 
JSeery's Avatar
 
Join Date: Nov 2012
Location: Wichita KS
Posts: 11,107
Default Re: 50 flatty idles well revs okay, but will not drive down the road.

Quote:
Originally Posted by trentclark View Post
reinstalled and now when it is running i dont get a drain on my battery like before it just stays level a 12.30 volts. shouldnt it ramp up the voltage when I rev the motor?
Should be in the mid 14 volt range at say 2000 rpm.
JSeery is offline   Reply With Quote
Old 08-29-2018, 09:24 PM   #68
trentclark
Junior Member
 
Join Date: Aug 2017
Posts: 5
Default Re: 50 flatty idles well revs okay, but will not drive down the road.

yes, generator is not doing it. I will check on a new regulator.
trentclark is offline   Reply With Quote
Old 08-29-2018, 09:31 PM   #69
trentclark
Junior Member
 
Join Date: Aug 2017
Posts: 5
Default Re: 50 flatty idles well revs okay, but will not drive down the road.

found the main problem. had a clog in the gas tank valve. rust build up in the tank. it would let enough thru to run and idle well but not to go down the road. cant believe I missed this. I thoroughly cleaned out the tank a few years ago but now there is a fine layer of rust. enough flaked off to clog the valve. I am derusting the tank with evapo-rust. have new lines, new pump, filter ready for the clean tank. this problem helped me find a slew of other issues to fix and I appreciate the help. I will reinstall the tank this weekend and let you know how it goes. it better run this time...... still need to fix the generator then I will have a daily driver again.
trentclark is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Sponsored Links (Register now to hide all advertisements)


All times are GMT -5. The time now is 03:03 AM.