Go Back   The Ford Barn > General Discussion > Early V8 (1932-53)

Sponsored Links (Register now to hide all advertisements)

Reply
 
Thread Tools Display Modes
Old 09-08-2013, 04:19 PM   #1
john hamilton
Senior Member
 
john hamilton's Avatar
 
Join Date: May 2010
Location: Waxahachie, Texas
Posts: 241
Default V8-60 water pumps

Had water running into the crankcase and got a lot of good advice that showed it was the waterpumps. Got rebuilding kits and rebuilt both. The cores are the ones that came from the engine.

Rebuilding kits included shafts with bearings, bushings, rotors, springs and the rubber noses.

Filled the radiator and engine and turned the water pumps over by hand. Water ran down from the front of the engine - looks like over the crankshaft.

Took everything apart and checked it but didn't find a problem so put it back together lubricating the rubber seals like you would an oil filter.

Filled the radiator and engine again and the water ran out the same way.

These pumps have two small rubber bands, a large copper seal and large gasket. What am I missing?????? Thank you for all your help in the past.
john hamilton is offline   Reply With Quote
Old 09-09-2013, 08:09 AM   #2
MARVIN, CT
Member
 
MARVIN, CT's Avatar
 
Join Date: May 2010
Location: Preston,ct
Posts: 76
Default Re: V8-60 water pumps

John, from what I've learned, the early tapered pumps only use the small rubber bands and the later type only use the gaskets . You can't use both. Good luck, Marvin,ct
MARVIN, CT is offline   Reply With Quote
Sponsored Links (Register now to hide all advertisements)
Old 09-09-2013, 08:31 AM   #3
Kurt in NJ
Senior Member
 
Kurt in NJ's Avatar
 
Join Date: May 2010
Location: on the Littlefield
Posts: 4,741
Default Re: V8-60 water pumps

If the surface on the face of the waterpump that the rubber impellers rub on is rough or pitted they will leak --the rubber againt the smooth face of the pump is the seal.
Kurt in NJ is offline   Reply With Quote
Old 09-09-2013, 03:30 PM   #4
john hamilton
Senior Member
 
john hamilton's Avatar
 
Join Date: May 2010
Location: Waxahachie, Texas
Posts: 241
Default Re: V8-60 water pumps

Thanks, I'll check both of these. The gaskets came in the kits but there weren't any instructions.
john hamilton is offline   Reply With Quote
Old 09-09-2013, 10:08 PM   #5
3quarter32
Senior Member
 
3quarter32's Avatar
 
Join Date: Feb 2012
Location: Broken Arrow, OK
Posts: 119
Default Re: V8-60 water pumps

I had to shorten the shafts on mine (a few thousands at a time) until the impeller fit flush on the base of the housing. If you can see any day light between the two, it will leak. Mine are the tapered type. I have no gaskets, only the two rings.
3quarter32 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Sponsored Links (Register now to hide all advertisements)


All times are GMT -5. The time now is 04:58 PM.