Go Back   The Ford Barn > General Discussion > Early V8 (1932-53)

Sponsored Links (Register now to hide all advertisements)

Reply
 
Thread Tools Display Modes
Old 01-07-2016, 10:57 AM   #1
Lenny51
Member
 
Lenny51's Avatar
 
Join Date: Jun 2015
Location: Atlanta Ga
Posts: 82
Default Overdrive not working

I know this has been talked about many times so far installed a new kick down switch & relay I read on one forum you can take the solenoid apart &
clean it can you take the governor apart to clean it not getting a click at solenoid 6 volt system original wiring checked with car on jack stands.
trying to read all posts on all Ford forums
Lenny51 is offline   Reply With Quote
Old 01-07-2016, 11:05 AM   #2
Willit Stop
Senior Member
 
Willit Stop's Avatar
 
Join Date: Feb 2013
Location: Eureka Calif.
Posts: 889
Default Re: Overdrive not working

I don't know squat about overdrives but hopefully this will help you.
http://www.btc-bci.com/~billben/flathead.htm
Willit Stop is offline   Reply With Quote
Sponsored Links (Register now to hide all advertisements)
Old 01-07-2016, 11:25 AM   #3
Blu Dice
Senior Member
 
Blu Dice's Avatar
 
Join Date: Jul 2010
Location: Plainfield, IN
Posts: 360
Default Re: Overdrive not working

If you're still 6 volt - original wiring I suggest you check and double check all the grounds. Also check the generator output and check the battery too. OD are very sensitive to voltage drop - requires full 30 amps to pull the solenoid. My '50 always gave me fits at night when driving with the lights on. Ford made a couple changes in '51 so I'm not sure if you still have the pull out lever under the dash or not - check the fuse and connections on the firewall too if you haven't already.
__________________
4 doors are better than no doors!
Blu Dice is offline   Reply With Quote
Old 01-07-2016, 11:41 AM   #4
Mike51Merc
Senior Member
 
Mike51Merc's Avatar
 
Join Date: May 2010
Location: Northeast Pennsylvania
Posts: 1,575
Default Re: Overdrive not working

Did it work before you put the new parts in, or were the parts an attempt at repair?
Mike51Merc is offline   Reply With Quote
Old 01-07-2016, 12:23 PM   #5
flatheadmurre
Senior Member
 
flatheadmurre's Avatar
 
Join Date: Apr 2015
Location: Sweden
Posts: 3,045
Default Re: Overdrive not working

The electrical cicuit is simple.
Feed goes into kickdown switch not activated you should have full voltage there.
Afer that through governor that is open until you reach enough speed for activation.
The solenoid should click if activated with a clipwire...if its ok.
And a volt meter should be able to give you a hint if you have full voltage or bad wiring/switches/fuses...
flatheadmurre is offline   Reply With Quote
Old 01-07-2016, 02:00 PM   #6
Ardun
Senior Member
 
Ardun's Avatar
 
Join Date: Jun 2013
Location: Reno
Posts: 143
Default Re: Overdrive not working

I had nothing but problems wit the repo kick down switches. Bout a good used one and no further problem. They need to be checked with an ohm meter to be sure the are working correctly. Took my solenoid apart, cleaned it well and all worked great.

With all get said, I took out the O.D. And put n an AOD. Love it...
Ardun is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Sponsored Links (Register now to hide all advertisements)


All times are GMT -5. The time now is 01:21 AM.