Go Back   The Ford Barn > General Discussion > Model A (1928-31)

Sponsored Links (Register now to hide all advertisements)

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 11-20-2019, 05:43 PM   #1
RSK
Junior Member
 
Join Date: Nov 2019
Posts: 1
Default Rsk

1929 Fordor with stock engine & transmission (except with modern upper plate points & condenser). Was running good b4 being parked several months. After being parked it started and ran good except when pulling forward from a stop or going up hill, when it lurched and bucked terribly. When backing up the same hill it ran fine. It starts & idles very well.
Here's what I've done so far without improvement:
1 Made sure gas tank was at least 1/2 full with fresh gas without alcohol
2 Cleaned filter on the fire wall
3 Had carburetor professionally cleaned
4 Replaced points and condenser
5 Replaced coil
6 Retimed
7 Replaced condenser again
8 Compression test OK
9 Plugs were black and sooty. Cleaned off what I could.
10 Put about 1 oz Marvel Mystery Oil in each cylinder, rotated engine and
reinstalled plugs and let it sit for 5 days
11 Added Marvel Mystery Oil to gas according to instructions on bottle.
When going uphill & it starts to lurch I immediately stop & disconnect gas line from carburetor & gas flow is good. Nothing I did helped lurching.
Any criticism, advice, or suggestions would be greatly appreciated.
RSK is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Sponsored Links (Register now to hide all advertisements)


All times are GMT -5. The time now is 11:47 AM.