Go Back   The Ford Barn > General Discussion > Late V8 (1954+)

Sponsored Links (Register now to hide all advertisements)

Reply
 
Thread Tools Display Modes
Old 11-05-2020, 11:57 AM   #81
yblock57
Junior Member
 
yblock57's Avatar
 
Join Date: Oct 2020
Location: Round Rock, TX
Posts: 25
Default Re: Fordomatic late shifting ('57 thunderbird)

Daves55Sedan

I should've been more clear in my original post. This setup had linkage issues due to the throttle valve being installed wrong in the valve body which limited the movement of the throttle rod. Dad drove the car before we realized what was going on and inadvertently floored the accelerator to get the trans to kick-down. This caused the throttle to become stuck in the wide-open position (or close to wide-open). He had to turn the key off. Luckily no damage to the engine or car, but it bent the threaded end of the throttle rod and unbeknown to us, the 'double-L' piece on the firewall.

Once I ascertained all my pieces were correct for a '57 D model (measured a friend's correct setup), I pulled the 'double-L' piece out of the car and proceeded to carefully bend it in the direction if needed to go. The ease at which it bent left no doubt in my mind that this was the key to all this linkage mess.

Once it went back in, the shop manual procedures were followed and this time everything went exactly as outlined.

Appreciate everyone's input here. I should be putting it all back together sometime next week and will post my results. Fingers crossed!
__________________
Kent

'56 F-100 | '56 Crown Vic | '57 Fairlaine 500 | '57 Thunderbird
yblock57 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Sponsored Links (Register now to hide all advertisements)


All times are GMT -5. The time now is 04:01 AM.