Go Back   The Ford Barn > General Discussion > Model A (1928-31)

Sponsored Links (Register now to hide all advertisements)

Reply
 
Thread Tools Display Modes
Old 12-06-2017, 08:03 PM   #1
Tinbasher
Senior Member
 
Tinbasher's Avatar
 
Join Date: May 2010
Location: Innisfil, Ontario Canada
Posts: 779
Default Clutch Problems sorted out

Hi Guys: Well I finally have the clutch sorted out on my 28 sport coupe. The problem came down to the pressure plate being worn out with weak springs and the fingers about 1/3 of the thickness they should have been. So now the car has a new clutch disc and pressure plate. The throw out bearing and pilot bear are new so I was good there. Then I got everything back together and sorted out and the clutch still wouldn't allow the transmission to be shifted. That came down to too much free play in the clutch pedal adjustment. Closed that adjustment up and I'm finally ready to test drive the car. I couldn't believe the free play was so critical. So it's suppose to snow tomorrow but it might be clear on the weekend. Maybe a test drive this weekend!!

Thanks for all of your help.

John Poole "The Old Tinbasher"
Tinbasher is offline   Reply With Quote
Old 12-06-2017, 10:24 PM   #2
Tom Endy
Senior Member
 
Tom Endy's Avatar
 
Join Date: May 2010
Location: Southern California
Posts: 2,157
Default Re: Clutch Problems sorted out

Hopefully you checked the adjustment of the fingers of the new pressure plate. The story is they come from the factory already properly adjusted. Good luck with that one. It is prudent to check that the adjustment is correct before the installation is complete. It can still be adjusted through the inspection cover on the bell housing, but it is more difficult.

See attached article.

Tom Endy
Attached Files
File Type: pdf clutch adj article.pdf (86.8 KB, 34 views)
Tom Endy is online now   Reply With Quote
Sponsored Links (Register now to hide all advertisements)
Old 12-07-2017, 08:59 PM   #3
Tinbasher
Senior Member
 
Tinbasher's Avatar
 
Join Date: May 2010
Location: Innisfil, Ontario Canada
Posts: 779
Default Re: Clutch Problems sorted out

Thanks Tom: Yes we did that setup before installing the transmission. JP
Tinbasher is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Sponsored Links (Register now to hide all advertisements)


All times are GMT -5. The time now is 03:44 PM.