Go Back   The Ford Barn > General Discussion > Early V8 (1932-53)

Sponsored Links (Register now to hide all advertisements)

Reply
 
Thread Tools Display Modes
Old 07-13-2020, 01:05 PM   #1
grumppyoldman
Senior Member
 
grumppyoldman's Avatar
 
Join Date: Apr 2017
Location: Texas Gulf Coast
Posts: 706
Default New aluminum radiator

Took 41 with Champion aluminum radiator out for a run in 100 deg. temp. it still runs at 175 degrees. looks like it will be OK. Has 173 degree thermostats, had a leak in upper hose, fixed this morning had clamp too high on head neck. Al
grumppyoldman is offline   Reply With Quote
Old 07-13-2020, 03:29 PM   #2
corvette8n
Senior Member
 
corvette8n's Avatar
 
Join Date: Jul 2010
Location: 36 miles north of Albany NY
Posts: 2,017
Default Re: New aluminum radiator

Seem like it's working ok, got any video of your ride?.
corvette8n is offline   Reply With Quote
Sponsored Links (Register now to hide all advertisements)
Old 07-15-2020, 04:41 PM   #3
grumppyoldman
Senior Member
 
grumppyoldman's Avatar
 
Join Date: Apr 2017
Location: Texas Gulf Coast
Posts: 706
Default Re: New aluminum radiator

Sponsored Links (Register now to hide all advertisements)
Not yet, can' get my camera batteries charged when I have time to do it. Want someone to video it going down road also. Al
grumppyoldman is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Sponsored Links (Register now to hide all advertisements)


All times are GMT -5. The time now is 04:15 AM.