Go Back   The Ford Barn > General Discussion > Early V8 (1932-53)

Sponsored Links (Register now to hide all advertisements)

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 07-15-2020, 07:42 PM   #1
Lee Mitch
Senior Member
 
Join Date: Feb 2011
Location: Sandy, OR.
Posts: 141
Default Fan came apart!!

First time posting on this side of FB as I am a Model A guy.


I picked up this pretty nice stock '39 pickup a little over a year ago and just got it back on the road. Test drive #2 and the metal fan blew apart and really caused some ugly damage. I've heard of this happening in Model A's, so that it why some of us put on those ugly plastic fans.
The previous owner had upgraded to a 12V system and I think that is where the problems began.



I need your help. When switching to a 12V system, is there a conversion kit that includes a fan and spacer that attaches to the new alternator? Is this sold as a complete unit? I don't know where to start on this and could use some ideas, perhaps some vendors and or parts numbers.



Give me your ideas guys! Thank you!
Attached Images
File Type: jpg hood side panel 2.jpg (73.8 KB, 786 views)
File Type: jpg hood 2.jpg (43.5 KB, 274 views)
File Type: jpg radiator.jpg (38.9 KB, 291 views)
File Type: jpg fan.jpg (85.7 KB, 320 views)
Lee Mitch is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Sponsored Links (Register now to hide all advertisements)


All times are GMT -5. The time now is 05:35 AM.